Re: [PATCH 2/2] kvm: rename KVM_MAX_VCPU_ID to KVM_MAX_VCPU_IDS
Sean Christopherson <[email protected]>
| Newsgroups | org.kernel.vger.kvm-ppc,org.kernel.vger.kvm,org.kernel.vger.linux-doc,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.linux-mips,org.ozlabs.lists.linuxppc-dev |
|---|---|
| Message-ID | <[email protected]> |
On Mon, Sep 13, 2021, Juergen Gross wrote: > KVM_MAX_VCPU_ID is not specifying the highest allowed vcpu-id, but the > number of allowed vcpu-ids. This has already led to confusion, so > rename KVM_MAX_VCPU_ID to KVM_MAX_VCPU_IDS to make its semantics more > clear My hesitation with this rename is that the max _number_ of IDs is not the same thing as the max allowed ID. E.g. on x86, given a capability that enumerates the max number of IDs, I would expect to be able to create vCPUs with arbitrary 32-bit x2APIC IDs so long as the total number of IDs is below the max.