Re: Moved eth_* to ne2k_* for future expansion

Marc-François LUCCA-DANIAU <[email protected]> Sat, 4 Mar 2017 18:48:59 +0100
Newsgroups org.kernel.vger.linux-8086
Message-ID <CACpuWUkrFgweb2ctm+djjyZ0BszaZRAssKafzuuDT6Nsjg-qNw@mail.gmail.com>
OK for the changes that seem logical to me, except:

* elks/arch/i86/drivers/net/ne2k-main.c : I actually planned to rename
this file eth-main.c, because the pattern of any Ethernet driver is
the same, and will implement the same "fops". Only the call to ne2k_*
functions are specific. So we should keep the eth_* functions inside
this module, that are generic.

* elks/arch/i86/drivers/net/ne2k-test.c : renaming the variables
related to Ethernet protocol and not linked to the NE2K has no sense :
ne2k_from and ne2k_to, for example, are MAC adresses, and do not
depend on the underlying Ethernet device. So we should rename them
back to eth_from and eth_to.

* elkscmd/test/socket/echo/.gitignore : I believe that Georg removed
*_un and *_in programs, and replaced them by more generic programs ?
If confirmed, remove *_un and *_in.

* qemu.sh : "system" keyword means that we use the "QEMU system
emulator". Not the "QEMU program emulator", that is not the same. So
keep that accurate comment.

MFLD




2017-03-04 17:46 GMT+01:00 Jody Bruchon <[email protected]>:
> I generalized some network stuff in case other network adapters are
> supported in the future. Make sure I didn't break anything,
>
> -Jody
> --
> To unsubscribe from this list: send the line "unsubscribe linux-8086" in
> the body of a message to [email protected]
> More majordomo info at  http://vger.kernel.org/majordomo-info.html