Re: Moved eth_* to ne2k_* for future expansion
"Georg Potthast" <[email protected]> Sun, 5 Mar 2017 21:37:45 +0100
| Newsgroups | org.kernel.vger.linux-8086 |
|---|---|
| Message-ID | <5F3114D4BFAD484086638649225A66F2@PotthastHP> |
When I look at the drivers in the char directory, most implement their own version of a fops structure and have an init function for the kernel. So I would expect that an RTL NIC driver would have the same structure as the NE2K driver, again with a fops structure and an init function. I would rather use this template than branch to various specific functions from a generic ethernet driver. This mainly because that has been the pattern used by ELKS so far and the developers may be more familiar with it. The *_un and *_in files have been deleted in the "elkscmd/test/socket/echo" directory and are replaced with echoserver and echoclient files that will use unix domain sockets if "-u" is passed on the command line. Georg -----Ursprüngliche Nachricht----- From: Marc-François LUCCA-DANIAU Sent: Saturday, March 4, 2017 6:48 PM To: ELKS Subject: Re: Moved eth_* to ne2k_* for future expansion OK for the changes that seem logical to me, except: * elks/arch/i86/drivers/net/ne2k-main.c : I actually planned to rename this file eth-main.c, because the pattern of any Ethernet driver is the same, and will implement the same "fops". Only the call to ne2k_* functions are specific. So we should keep the eth_* functions inside this module, that are generic. * elks/arch/i86/drivers/net/ne2k-test.c : renaming the variables related to Ethernet protocol and not linked to the NE2K has no sense : ne2k_from and ne2k_to, for example, are MAC adresses, and do not depend on the underlying Ethernet device. So we should rename them back to eth_from and eth_to. * elkscmd/test/socket/echo/.gitignore : I believe that Georg removed *_un and *_in programs, and replaced them by more generic programs ? If confirmed, remove *_un and *_in. * qemu.sh : "system" keyword means that we use the "QEMU system emulator". Not the "QEMU program emulator", that is not the same. So keep that accurate comment. MFLD 2017-03-04 17:46 GMT+01:00 Jody Bruchon <[email protected]>: > I generalized some network stuff in case other network adapters are > supported in the future. Make sure I didn't break anything, > > -Jody > -- > To unsubscribe from this list: send the line "unsubscribe linux-8086" in > the body of a message to [email protected] > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-8086" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html