Re: [PATCH v1 12/17] ACPI: processor: idle: Introduce too_many_states() for _LPI
"lihuisong (C)" <[email protected]>
| Newsgroups | org.kernel.vger.linux-acpi,org.kernel.vger.linux-pm |
|---|---|
| Message-ID | <[email protected]> |
On 7/9/2026 8:39 PM, Rafael J. Wysocki wrote: > From: "Rafael J. Wysocki" <[email protected]> > > To reduce code duplication, introduce a function called too_many_states() > that will check if the total number of _LPI states for a given CPU is > too large and print a message in that case. > > Use that function in flatten_lpi_states() and acpi_processor_get_lpi_info(). > > No functional impact beyond reducing dynamic debug flexibility. > > Signed-off-by: Rafael J. Wysocki <[email protected]> > --- Acked-by: Huisong Li <[email protected]>