[PATCH v1 4/7] ACPI: scan: Combine two conditionals in acpi_bus_attach()
"Rafael J. Wysocki" <[email protected]>
| Newsgroups | org.kernel.vger.linux-acpi,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci,org.kernel.vger.linux-pm |
|---|---|
| Organization | Linux Kernel Development - Intel |
| Message-ID | <[email protected]> |
From: "Rafael J. Wysocki" <[email protected]> There are two conditionals in acpi_bus_attach() that can be combined, which slightly reduces the overhead and makes the code a bit easier to follow, so do that. No intentional functional impact. Signed-off-by: Rafael J. Wysocki <[email protected]> --- drivers/acpi/scan.c | 11 +++-------- 1 file changed, 3 insertions(+), 8 deletions(-) diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c index 019a43e3b5d7..8c5a2fcef582 100644 --- a/drivers/acpi/scan.c +++ b/drivers/acpi/scan.c @@ -2370,16 +2370,11 @@ static int acpi_bus_attach(struct acpi_device *device, void *first_pass) if (ret < 0) return 0; - if (ret > 0 && !device->flags.enumeration_by_parent) { + if (!device->flags.enumeration_by_parent && (ret > 0 || + (!device->pnp.type.platform_id && !device->pnp.type.backlight))) acpi_device_set_enumerated(device); - goto ok; - } - - if (device->pnp.type.platform_id || device->pnp.type.backlight || - device->flags.enumeration_by_parent) - acpi_default_enumeration(device); else - acpi_device_set_enumerated(device); + acpi_default_enumeration(device); ok: acpi_dev_for_each_child(device, acpi_bus_attach, first_pass); -- 2.51.0