Re: [PATCH v5 13/23] alpha/PCI: Use PCI resource accessor macros

Krzysztof WilczyƄski <[email protected]> Wed, 22 Apr 2026 03:43:43 +0900
Newsgroups org.kernel.vger.linux-alpha,org.kernel.vger.linux-pci,org.ozlabs.lists.linuxppc-dev
Message-ID <20260421184343.GB1684602@rocinante>
Hello,

> Replace direct pdev->resource[] accesses with pci_resource_n(),
> and pdev->resource[].flags accesses with pci_resource_flags().

Will update the commit message when sending next version, as the
pci_resource_flags() was replaced with the new helpers.

> Also, replace open-coded res->flags type checks with new
> pci_resource_is_mem() and pci_resource_start() helpers.

Thank you!

	Krzysztof