Re: [PATCH v8 00/25] PCI: Convert all dynamic sysfs attributes to static
Krzysztof WilczyĆski <[email protected]> Sat, 20 Jun 2026 03:39:03 +0900
| Newsgroups | org.kernel.vger.linux-alpha,org.kernel.vger.linux-pci,org.ozlabs.lists.linuxppc-dev |
|---|---|
| Message-ID | <20260619183229.GC2528910@rocinante> |
Hello, > This series converts every dynamically allocated PCI sysfs attribute to > a static const definition. After the full series, pci_sysfs_init() and > sysfs_initialized are gone, and every sysfs file is created by the > driver model at device_add() time. [...] > Changes in v8: > https://lore.kernel.org/linux-pci/[email protected]/ > > - Renamed the generic resource attributes from dev_resourceN_{io,uc,wc}_attr > to pci_dev_resourceN_{io,uc,wc}_attr, for consistency, and cleaned up > resource macros definitions. > - Changed resource macros argument order to fix checkpatch.pl > complaint. > - Added two new macros, pci_legacy_resource_io_attr() and > pci_legacy_resource_mem_attr(), used for the legacy I/O and memory > conversion instead of open-coding each struct bin_attribute. No > functional changes intended. Updated the sysfs branch with this revision to get some testing coverage. Changes here are mainly to clean some things up before the code potentially lands in the mainline. No functional changes whatsoever. Thank you! Krzysztof