Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Thomas Gleixner <[email protected]> Fri, 03 Jul 2026 22:52:43 +0200
| Newsgroups | org.kernel.vger.linux-alpha,dev.linux.lists.loongarch,org.infradead.lists.linux-riscv,org.infradead.lists.linux-um,org.kernel.vger.linux-csky,org.kernel.vger.linux-kernel,org.kernel.vger.linux-m68k,org.kernel.vger.linux-mips,org.kernel.vger.linux-parisc,org.kernel.vger.linux-s390,org.kernel.vger.linux-sh,org.kvack.linux-mm,org.ozlabs.lists.linuxppc-dev |
|---|---|
| Message-ID | <87echjlrs4.ffs@fw13> |
On Fri, Jul 03 2026 at 13:59, Kevin Brodsky wrote: > On 03/07/2026 12:27, Michal Suchánek wrote: >>> If we're changing the return type, it might be worth renaming the >>> function something like: >>> >>> seccomp_permits_syscall() >> Then not only it is clear which way the boolean value should be >> interpreted, it also pervents the accidental inversion of existing >> calls. Overall great. > > Totally agreed, if we have the opportunity to rename a completely > undescriptive function name like "secure_computing" we should take it. Absolutely no objections from my side on that.