Re: [PATCH v8 00/25] PCI: Convert all dynamic sysfs attributes to static

Krzysztof WilczyƄski <[email protected]> Tue, 7 Jul 2026 02:59:36 +0900
Newsgroups org.kernel.vger.linux-alpha,org.kernel.vger.linux-pci,org.ozlabs.lists.linuxppc-dev
Message-ID <20260706175653.GB265195@rocinante>
Hello,

> Changes in v8:
>   https://lore.kernel.org/linux-pci/[email protected]/
> 
>   - Renamed the generic resource attributes from dev_resourceN_{io,uc,wc}_attr
>     to pci_dev_resourceN_{io,uc,wc}_attr, for consistency, and cleaned up
>     resource macros definitions.
>   - Changed resource macros argument order to fix checkpatch.pl
>     complaint.
>   - Added two new macros, pci_legacy_resource_io_attr() and
>     pci_legacy_resource_mem_attr(), used for the legacy I/O and memory
>     conversion instead of open-coding each struct bin_attribute.  No
>     functional changes intended.

I will send a follow-up patch with the above changed, mainly to
clean the code up, as v8 didn't made it in time before the merge
window closed.  There were no functional changes.

Thank you!

	Krzysztof