[PATCH v7 0/3] riscv: fix PIO helpers and add optimized percpu ops
Yunhui Cui <[email protected]>
| Newsgroups | org.kernel.vger.linux-arch,dev.linux.lists.llvm,org.infradead.lists.linux-riscv,org.kernel.vger.bpf,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
Changes in v7: - Address the Sashiko comment about inconsistent AND helper naming: rename the RISC-V internal percpu helpers from andnot to and, and make all this_cpu_and_*() wrappers pass the operand directly. This is a readability cleanup only; the generated operations still implement the same plain AND semantics required by this_cpu_and(). - Undefine internal percpu helper macros prior to including <asm-generic/percpu.h> as recommended by bpf-ci/Sashiko review. This prevents macro leakage into the global namespace and has no impact on generated code or runtime behavior. Yunhui Cui (3): riscv: io: avoid null-pointer arithmetic in PIO helpers riscv: introduce percpu.h into include/asm riscv: store percpu offset into thread_info arch/riscv/include/asm/asm.h | 6 +- arch/riscv/include/asm/io.h | 8 + arch/riscv/include/asm/percpu.h | 300 +++++++++++++++++++++++++++ arch/riscv/include/asm/switch_to.h | 8 + arch/riscv/include/asm/thread_info.h | 3 +- arch/riscv/kernel/asm-offsets.c | 1 + arch/riscv/kernel/smpboot.c | 8 + arch/riscv/net/bpf_jit_comp64.c | 9 +- 8 files changed, 329 insertions(+), 14 deletions(-) create mode 100644 arch/riscv/include/asm/percpu.h -- 2.39.5