[PATCH 0/4] kho: rename "scratch" to "bootmem"
Pratyush Yadav <[email protected]>
| Newsgroups | org.kernel.vger.linux-arch,org.infradead.lists.kexec,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-doc,org.kernel.vger.linux-efi,org.kernel.vger.linux-kernel,org.kvack.linux-mm |
|---|---|
| Message-ID | <[email protected]> |
From: "Pratyush Yadav (Google)" <[email protected]> The term "KHO scratch" is vague and overloaded. It does not accurately describe what the memory is for. This was discussed previously at [0]. The conclusion was to rename "KHO scratch" to "KHO bootmem", since this is memory passed by the previous kernel for early boot allocations. In addition, memblock does not care about the provenance of the memory. It cares more about how it should use it. Use MEMBLOCK_KHO_NOPRSRV, instead of MEMBLOCK_KHO_SCRATCH, to describe this memory to memblock. This series does the renames. It also gets rid of a redundant Kconfig. While the diffstat is big and scary, most of the changes are mechanical. The most interesting functional change is in patch 4. This series touches a lot of files across a lot of trees. But since all of that is purely KHO-related code, I would like to collect ACKs from the maintainers and take it via the liveupdate tree. Ideally we should queue it in liveupdate/next early in the v7.4 cycle since it will cause a lot of conflicts with other patches throughout the KHO tree. [0] https://lore.kernel.org/kexec/[email protected]/T/#u Pratyush Yadav (Google) (4): memblock: get rid of CONFIG_MEMBLOCK_KHO_SCRATCH memblock: rename KHO_SCRATCH to KHO_NOPRSRV kho: rename KHO scratch to KHO bootmem kho: rename kho_scratch= commandline parameter to kho_bootmem= .../admin-guide/kernel-parameters.txt | 15 +- Documentation/admin-guide/mm/kho.rst | 18 +- Documentation/core-api/kho/index.rst | 36 +- arch/x86/boot/compressed/kaslr.c | 12 +- arch/x86/include/uapi/asm/setup_data.h | 4 +- arch/x86/kernel/e820.c | 2 +- arch/x86/kernel/kexec-bzimage64.c | 6 +- arch/x86/kernel/setup.c | 2 +- arch/x86/realmode/init.c | 2 +- drivers/firmware/efi/efi-init.c | 6 +- drivers/of/kexec.c | 16 +- include/asm-generic/kexec_handover.h | 2 +- include/linux/kexec.h | 2 +- include/linux/kexec_handover.h | 16 +- include/linux/memblock.h | 30 +- kernel/liveupdate/Kconfig | 1 - kernel/liveupdate/kexec_handover.c | 340 +++++++++--------- kernel/liveupdate/kexec_handover_debugfs.c | 24 +- kernel/liveupdate/kexec_handover_internal.h | 4 +- mm/Kconfig | 4 - mm/memblock.c | 56 +-- mm/mm_init.c | 6 +- tools/testing/memblock/internal.h | 2 +- 23 files changed, 302 insertions(+), 304 deletions(-) base-commit: 352ebb57013a08679788bc18c7f9af90903db256 -- 2.55.0.679.g6767b8d81c-goog