Re: [PATCH kvm-next V11 4/7] KVM: guest_memfd: Use guest mem inodes instead of anonymous inodes
"Garg, Shivank" <[email protected]> Thu, 28 Aug 2025 11:19:42 +0530
| Newsgroups | org.kernel.vger.linux-bcachefs,dev.linux.lists.linux-coco,net.sourceforge.lists.linux-f2fs-devel,org.kernel.vger.kvm,org.kernel.vger.linux-btrfs,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.linux-security-module,org.kvack.linux-mm,org.ozlabs.lists.linux-erofs |
|---|---|
| Message-ID | <[email protected]> |
On 8/28/2025 4:13 AM, Ackerley Tng wrote: > Shivank Garg <[email protected]> writes: > >> >> [...snip...] >> > > I meant to send this to you before this version went out but you were > too quick! I wanted to get it merged quickly ;) > > Here's a new version, Fuad and I reviewed this again internally. The > changes are: > > + Sort linux/pseudo_fs.h after linux/pagemap.h (alphabetical) > + Don't set MNT_NOEXEC on the mount, since SB_I_NOEXEC was already set > on the superblock > + Rename kvm_gmem_inode_make_secure_inode() to kvm_gmem_inode_create() > + Emphasizes that there is a creation in this function > + Remove "secure" from the function name to remove confusion that > there may be a "non-secure" version > + In kvm_gmem_inode_create_getfile()'s error path, return ERR_PTR(err) > directly instead of having a goto > Thanks for the quick update! The changes look good. I'll incorporate them in the next version. Best Regards, Shivank