Re: [PATCH 01/31] swim: Assert strobe with stable outputs
Laurent Vivier <[email protected]>
| Newsgroups | org.kernel.vger.linux-block,org.kernel.vger.linux-kernel,org.kernel.vger.linux-m68k |
|---|---|
| Message-ID | <[email protected]> |
Le 21/07/2026 à 09:37, Finn Thain a écrit : > > On Tue, 21 Jul 2026, Laurent Vivier wrote: > >> Le 21/07/2026 à 07:41, Finn Thain a écrit : >>> >>> On Mon, 20 Jul 2026, Laurent Vivier wrote: >>> >>>> Le 16/07/2026 à 12:02, Finn Thain a écrit : >>>> >>>>> Keep the four phase pin directions set to output and hold their levels >>>>> constant during LSTRB signalling. >>>> >>>> Perhaps you can also add a short comment to describe the changes you >>>> made to the defines. >>>> >>> >>> Can you clarify please? I think what you're asking is, shouldn't the PH3 >>> pin be an input when it's not being used for LSTRB signalling? >> >> My question is simpler: >> You added the directions bits in the defines and it's not clear in the commit >> message. >> For instance, I can see you update all the defines, but at first glance I >> didn't understand why. >> > > OK -- I see what you mean. It might be more idiomatic and more readable if > the the pin direction nybble were defined in a separate macro rather than > baked into every macro definition. E.g. #define PHASE_PIN_DIRECTION 0xF0 > The writes to the phase register would then get a bitwise OR with this new > macro. Would that work for you? Yes, perfectly. Thanks, Laurent