Re: [PATCH 25/31] swim: Move swd initialization

Laurent Vivier <[email protected]>
Newsgroups org.kernel.vger.linux-block,org.kernel.vger.linux-kernel,org.kernel.vger.linux-m68k
Message-ID <[email protected]>
Le 16/07/2026 à 12:02, Finn Thain a écrit :
> For better readability, initialize the swd backpointer along with the
> other floppy_state struct members. No functional change.
> 
> Signed-off-by: Finn Thain <[email protected]>
> ---
>   drivers/block/swim.c | 3 +--
>   1 file changed, 1 insertion(+), 2 deletions(-)

Reviewed-by: Laurent Vivier <[email protected]>

> 
> diff --git a/drivers/block/swim.c b/drivers/block/swim.c
> index 4679f554fec5..c41d56ab6c04 100644
> --- a/drivers/block/swim.c
> +++ b/drivers/block/swim.c
> @@ -760,6 +760,7 @@ static int swim_add_floppy(struct swim_priv *swd, enum drive_location location)
>   	struct floppy_state *fs = &swd->unit[swd->floppy_count];
>   	struct swim __iomem *base = swd->base;
>   
> +	fs->swd = swd;
>   	fs->location = location;
>   
>   	swim_motor(base, OFF);
> @@ -855,8 +856,6 @@ static int swim_floppy_init(struct platform_device *pdev)
>   			err = PTR_ERR(swd->unit[drive].disk);
>   			goto exit_put_disks;
>   		}
> -
> -		swd->unit[drive].swd = swd;
>   	}
>   
>   	for (drive = 0; drive < swd->floppy_count; drive++) {
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.