Re: [PATCH 02/14] block: refactor disk_revalidate_zone_resources()

Hannes Reinecke <[email protected]> Wed, 5 Aug 2026 13:23:55 +0200
Newsgroups org.kernel.vger.linux-block
Message-ID <[email protected]>
On 8/5/26 4:27 AM, Damien Le Moal wrote:
> The function disk_revalidate_zone_resources() is misnamed as it does not
> revalidate anything but rather allocates the revalidation arguments and
> then calls disk_alloc_zone_resources() to initialize the disk zone
> resources if they are needed and not already allocated.
> 
> Make this function less confusing by renaming it
> disk_init_revalidate_args() and moving the call to
> disk_alloc_zone_resources() into blk_revalidate_disk_zones(). As before,
> this function is only called if the zone resources are needed and not yet
> allocated.
> 
> Signed-off-by: Damien Le Moal <[email protected]>
> ---
>   block/blk-zoned.c | 69 ++++++++++++++++++++++++-----------------------
>   1 file changed, 36 insertions(+), 33 deletions(-)
> 
Reviewed-by: Hannes Reinecke <[email protected]>

Cheers,

Hannes
-- 
Dr. Hannes Reinecke                  Kernel Storage Architect
[email protected]                                +49 911 74053 688
SUSE Software Solutions GmbH, Frankenstr. 146, 90461 Nürnberg
HRB 36809 (AG Nürnberg), GF: I. Totev, A. McDonald, W. Knoblich