Re: [PATCH 0/2] Bluetooth: use named initializers for acpi_device_id
[email protected] Mon, 27 Jul 2026 20:50:06 +0000
| Newsgroups | org.kernel.vger.linux-bluetooth,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <178518540639.1412337.3111585831256595939.git-patchwork-notify@kernel.org> |
Hello: This series was applied to bluetooth/bluetooth-next.git (master) by Luiz Augusto von Dentz <[email protected]>: On Mon, 27 Jul 2026 16:51:50 +0100 you wrote: > This series is converting lists that contain the acpi_device_id > struct, which is defined in the include/linux/device-id/acpi.h > to makes use of named initializers (which they do not use currently). > This work is part of the on going effort in the kernel associated > with device-ids [1] > > The plan is to convert acpi_device_id::driver_data to have an anonymous > union, similarly to what was introduced for PCI and I2C device ID tables. > The goal is to increase type-safety (as most of the existing casts are gone), > to improve readability and to make use intent a bit more clear: > > [...] Here is the summary with links: - [1/2] Bluetooth: use a named initializer for acpi_device_id https://git.kernel.org/bluetooth/bluetooth-next/c/cca1639df8fb - [2/2] Bluetooth: hci_intel: drop unused assignment of acpi_device_id::driver_data https://git.kernel.org/bluetooth/bluetooth-next/c/1bbd8346bc3c You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html