Re: [RESEND PATCH blktrace v3 07/20] blkparse: pass magic to get_magic
Damien Le Moal <[email protected]> Mon, 24 Nov 2025 18:01:37 +0900
| Newsgroups | org.kernel.vger.linux-btrace,org.kernel.vger.linux-block |
|---|---|
| Organization | Western Digital Research |
| Message-ID | <[email protected]> |
On 2025/11/24 16:37, Johannes Thumshirn wrote: > Pass the magic value to get_magic() instead of the whole 'struct > blk_io_trace'. > > This is a preparation for distinguishing between two different types of > blktrace protocol versions in blkparse. > > Signed-off-by: Johannes Thumshirn <[email protected]> Reviewed-by: Damien Le Moal <[email protected]> -- Damien Le Moal Western Digital Research