Re: [PATCH] btrfs: open-code BTRFS_BYTES_TO_BLKS()
David Sterba <[email protected]> Tue, 21 Jul 2026 13:56:58 +0200
| Newsgroups | org.kernel.vger.linux-btrfs |
|---|---|
| Message-ID | <[email protected]> |
On Mon, Jul 20, 2026 at 06:26:52PM +0930, Qu Wenruo wrote: > That macro is only utilized 4 times, all inside file.c, meanwhile we > have tons of open-coded usages. > And since it's a macro, there is no proper type checks at all. > > There isn't much need for such a rarely utilized macro. > > Signed-off-by: Qu Wenruo <[email protected]> We do the direct sectorsize_bits calculations in other places too. Reviewed-by: David Sterba <[email protected]>