Re: [PATCH v10 04/11] clk: realtek: Introduce a common probe()
Brian Masney <[email protected]>
| Newsgroups | org.kernel.vger.linux-clk,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On Mon, Jul 13, 2026 at 11:56:23PM +0800, Yu-Chun Lin wrote: > From: Cheng-Yu Lee <[email protected]> > > Add rtk_clk_probe() to set up the shared regmap, register clock hardware, > and add the clock provider. > > Additionally, if the "#reset-cells" property is present in the device tree, > it creates and registers an auxiliary device using the provided aux_name. > This allows the dedicated reset driver to bind to this device, enabling > both clock and reset drivers to share the same regmap. > > Signed-off-by: Cheng-Yu Lee <[email protected]> > Co-developed-by: Yu-Chun Lin <[email protected]> > Signed-off-by: Yu-Chun Lin <[email protected]> > --- > Changes in v10: > Add 'aux_name' to 'struct rtk_clk_desc' > --- > MAINTAINERS | 1 + > drivers/clk/Kconfig | 1 + > drivers/clk/Makefile | 1 + > drivers/clk/realtek/Kconfig | 30 ++++++++++++ > drivers/clk/realtek/Makefile | 4 ++ > drivers/clk/realtek/clk-rtk-common.c | 70 ++++++++++++++++++++++++++++ > drivers/clk/realtek/clk-rtk-common.h | 37 +++++++++++++++ > 7 files changed, 144 insertions(+) > create mode 100644 drivers/clk/realtek/Kconfig > create mode 100644 drivers/clk/realtek/Makefile > create mode 100644 drivers/clk/realtek/clk-rtk-common.c > create mode 100644 drivers/clk/realtek/clk-rtk-common.h > > diff --git a/MAINTAINERS b/MAINTAINERS > index 02b34a53b258..1fffb1fc5de1 100644 > --- a/MAINTAINERS > +++ b/MAINTAINERS > @@ -22742,6 +22742,7 @@ L: [email protected] > L: [email protected] > S: Supported > F: Documentation/devicetree/bindings/clock/realtek* > +F: drivers/clk/realtek/* > F: drivers/reset/realtek/* > F: include/dt-bindings/clock/realtek* > F: include/dt-bindings/reset/realtek* > diff --git a/drivers/clk/Kconfig b/drivers/clk/Kconfig > index 1717ce75a907..97ad817457db 100644 > --- a/drivers/clk/Kconfig > +++ b/drivers/clk/Kconfig > @@ -525,6 +525,7 @@ source "drivers/clk/nuvoton/Kconfig" > source "drivers/clk/pistachio/Kconfig" > source "drivers/clk/qcom/Kconfig" > source "drivers/clk/ralink/Kconfig" > +source "drivers/clk/realtek/Kconfig" > source "drivers/clk/renesas/Kconfig" > source "drivers/clk/rockchip/Kconfig" > source "drivers/clk/samsung/Kconfig" > diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile > index cc108a75a900..b1aa373e9f84 100644 > --- a/drivers/clk/Makefile > +++ b/drivers/clk/Makefile > @@ -141,6 +141,7 @@ obj-$(CONFIG_COMMON_CLK_PISTACHIO) += pistachio/ > obj-$(CONFIG_COMMON_CLK_PXA) += pxa/ > obj-$(CONFIG_COMMON_CLK_QCOM) += qcom/ > obj-y += ralink/ > +obj-$(CONFIG_COMMON_CLK_REALTEK) += realtek/ > obj-y += renesas/ > obj-$(CONFIG_COMMON_CLK_ROCKCHIP) += rockchip/ > obj-$(CONFIG_COMMON_CLK_SAMSUNG) += samsung/ > diff --git a/drivers/clk/realtek/Kconfig b/drivers/clk/realtek/Kconfig > new file mode 100644 > index 000000000000..ed97531e321d > --- /dev/null > +++ b/drivers/clk/realtek/Kconfig > @@ -0,0 +1,30 @@ > +# SPDX-License-Identifier: GPL-2.0-only > +config COMMON_CLK_REALTEK > + tristate "Clock driver for Realtek SoCs" > + depends on ARCH_REALTEK || COMPILE_TEST > + default ARCH_REALTEK > + help > + Enable the common clock framework infrastructure for Realtek > + system-on-chip platforms. > + > + This provides the base support required by individual Realtek > + clock controller drivers to expose clocks to peripheral devices. > + > + If you have a Realtek-based platform, say Y. > + > +if COMMON_CLK_REALTEK > + > +config RTK_CLK_COMMON > + tristate "Realtek Clock Common" > + depends on RESET_CONTROLLER > + select AUXILIARY_BUS > + select MFD_SYSCON > + select RESET_RTK_COMMON > + help > + Common helper code shared by Realtek clock controller drivers. > + > + This provides utility functions and data structures used by > + multiple Realtek clock implementations, and include integration > + with reset controllers where required. > + > +endif > diff --git a/drivers/clk/realtek/Makefile b/drivers/clk/realtek/Makefile > new file mode 100644 > index 000000000000..13000ed4ba11 > --- /dev/null > +++ b/drivers/clk/realtek/Makefile > @@ -0,0 +1,4 @@ > +# SPDX-License-Identifier: GPL-2.0-only > +obj-$(CONFIG_RTK_CLK_COMMON) += clk-rtk.o > + > +clk-rtk-y += clk-rtk-common.o > diff --git a/drivers/clk/realtek/clk-rtk-common.c b/drivers/clk/realtek/clk-rtk-common.c > new file mode 100644 > index 000000000000..cea7d94313da > --- /dev/null > +++ b/drivers/clk/realtek/clk-rtk-common.c > @@ -0,0 +1,70 @@ > +// SPDX-License-Identifier: GPL-2.0-only > +/* > + * Copyright (C) 2019-2026 Realtek Semiconductor Corporation > + * Author: Cheng-Yu Lee <[email protected]> > + */ > + > +#include <linux/auxiliary_bus.h> > +#include <linux/device.h> > +#include <linux/export.h> > +#include <linux/mfd/syscon.h> > +#include <linux/module.h> > +#include <linux/platform_device.h> > +#include "clk-rtk-common.h" > + > +static int rtk_reset_controller_register(struct device *dev, const char *aux_name, > + struct regmap *map) > +{ > + struct auxiliary_device *adev; > + > + if (!of_property_present(dev->of_node, "#reset-cells")) > + return 0; > + > + if (!aux_name) { > + dev_err(dev, "DTS requires reset controller, but aux_name is missing\n"); > + return -EINVAL; > + } > + > + adev = devm_auxiliary_device_create(dev, aux_name, (void *)map); > + > + if (!adev) Remove extra newline > + return -ENOMEM; > + > + return 0; > +} > + > +int rtk_clk_probe(struct platform_device *pdev, const struct rtk_clk_desc *desc) > +{ > + struct device *dev = &pdev->dev; > + struct regmap *regmap; > + int i, ret; > + > + regmap = device_node_to_regmap(dev->of_node); > + if (IS_ERR(regmap)) > + return dev_err_probe(dev, PTR_ERR(regmap), "failed to get regmap\n"); > + > + for (i = 0; i < desc->num_clks; i++) > + desc->clks[i]->regmap = regmap; > + > + for (i = 0; i < desc->clk_data->num; i++) { > + struct clk_hw *hw = desc->clk_data->hws[i]; > + > + if (!hw) Remove extra newline. > + continue; > + > + ret = devm_clk_hw_register(dev, hw); > + if (ret) > + return dev_err_probe(dev, ret, "failed to register hw of clk%d\n", i); > + } > + > + ret = devm_of_clk_add_hw_provider(dev, of_clk_hw_onecell_get, > + desc->clk_data); > + if (ret) > + return dev_err_probe(dev, ret, "failed to add clock provider\n"); > + > + return rtk_reset_controller_register(dev, desc->aux_name, regmap); > +} > +EXPORT_SYMBOL_NS_GPL(rtk_clk_probe, "REALTEK_CLK"); > + > +MODULE_DESCRIPTION("Realtek clock infrastructure"); > +MODULE_LICENSE("GPL"); > diff --git a/drivers/clk/realtek/clk-rtk-common.h b/drivers/clk/realtek/clk-rtk-common.h > new file mode 100644 > index 000000000000..d2aee7f421b4 > --- /dev/null > +++ b/drivers/clk/realtek/clk-rtk-common.h > @@ -0,0 +1,37 @@ > +/* SPDX-License-Identifier: GPL-2.0-only */ > +/* > + * Copyright (C) 2016-2026 Realtek Semiconductor Corporation > + * Author: Cheng-Yu Lee <[email protected]> > + */ > + > +#ifndef __CLK_REALTEK_COMMON_H > +#define __CLK_REALTEK_COMMON_H > + > +#include <linux/clk-provider.h> > + > +#define __clk_regmap_hw(_p) ((_p)->hw) > + > +struct device; > +struct platform_device; > +struct regmap; > + > +struct clk_regmap { Please rename this to clk_rtk_regmap. drivers/clk/qcom/clk-regmap.h already has this name, and they won't collide, but it makes things like grep less ambiguous with a unique name. Brian