Re: [PATCH v4] crypto: rsassa-pkcs1 - Avoid cacheline sharing with underlying driver

Lukas Wunner <[email protected]> Thu, 30 Jul 2026 13:35:44 +0200
Newsgroups org.kernel.vger.linux-crypto,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On Thu, Jul 30, 2026 at 09:20:26PM +1000, Changwei Zou wrote:
> +++ b/crypto/rsassa-pkcs1.c
> @@ -227,6 +227,7 @@ static int rsassa_pkcs1_verify(struct crypto_sig *tfm,
>  	struct scatterlist sg;
>  	unsigned int dst_len;
>  	unsigned int pos;
> +	u8 *key_buf __free(kfree_sensitive) = NULL;
>  	u8 *out_buf;
>  	int err;
>

Hm, why use an additional key_buf variable instead of using the existing
out_buf?

key_buf also seems to be misnomer, the buffer contains a digest.

For neatness, could you move the new declaration up below the one for
child_req so that the variable declarations sort of adhere to inverse
christmas tree convention.

Thanks,

Lukas