Re: [RFC PATCH 02/34] ARM: mm: make 2-level pgd_t a scalar
David Laight <[email protected]> Tue, 14 Jul 2026 13:34:15 +0100
| Newsgroups | org.kernel.vger.linux-csky,dev.linux.lists.loongarch,org.infradead.lists.kvm-riscv,org.infradead.lists.linux-riscv,org.kernel.vger.linux-arch,org.kernel.vger.linux-kernel,org.kernel.vger.linux-m68k,org.kernel.vger.linux-mips,org.kernel.vger.linux-openrisc,org.kvack.linux-mm |
|---|---|
| Message-ID | <20260714133415.78e25654@pumpkin> |
On Mon, 13 Jul 2026 14:55:41 +0100 Yeoreum Yun <[email protected]> wrote: > From: "David Hildenbrand (Arm)" <[email protected]> > > We don't want pgd_t to be an array, as it prohibits returning it from a > function, like pgdp_get(). If you use a two element structure the compiler/ABI might be able to return that from a function in two registers. That might make the entire mess more readable ... David