Re: [PATCH v19 05/14] cxl: Rename find_cxl_port() to find_cxl_port_by_dport()

Alison Schofield <[email protected]> Mon, 3 Aug 2026 19:14:03 -0700
Newsgroups org.kernel.vger.linux-cxl,org.kernel.vger.linux-acpi,org.kernel.vger.linux-doc,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci
Message-ID <[email protected]>
On Mon, Aug 03, 2026 at 05:18:01PM -0500, Terry Bowman wrote:
> From: Dan Williams <[email protected]>
> 
> find_cxl_port() and find_cxl_port_by_uport() are internal port lookup
> functions that search the CXL bus by dport and uport respectively, but
> their names do not make the lookup method clear.
> 
> Rename find_cxl_port() to find_cxl_port_by_dport() to make the lookup
> method explicit and consistent with find_cxl_port_by_uport(). Both
> functions remain static to port.c; the upcoming patch that adds the
> first cross-file caller will widen their scope.
> 
> Make the same naming change to static helper __find_cxl_port_by_dport().
> 

Reviewed-by: Alison Schofield <[email protected]>