Re: [PATCH net-next v3 2/4] mfd: add X-Powers AC200 support

[email protected]
Newsgroups org.kernel.vger.linux-devicetree,dev.linux.lists.mfd
Message-ID <[email protected]>
Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider:
- [Low] The commit message prefix does not follow the required MFD subsystem format.
- [Low] The private data structure instance uses the device name instead of 'ddata'.
- [Low] The `i2c_device_id` array does not use named initializers.
--

--- Patch [2]: [PATCH net-next v3 2/4] mfd: add X-Powers AC200 support ---
commit f27704a7e16fcc27a2ce774a23d85d9a4464373b
Author: James Hilliard <[email protected]>

mfd: add X-Powers AC200 support

This commit adds core MFD support for the X-Powers AC200 mixed-signal companion
IC. It enables package supplies and input clock, initializes the paged regmap,
and sets up basic chip reset and teardown handling.

> mfd: add X-Powers AC200 support

[Severity: Low]
This isn't a bug, but does the commit message prefix follow the MFD subsystem
formatting guidelines? The expected format requires a driver name and a
capitalized description, such as mfd: ac200: Add X-Powers AC200 support.

> diff --git a/drivers/mfd/ac200.c b/drivers/mfd/ac200.c
> index 0000000000000..e8346a3faad5e
> --- /dev/null
> +++ b/drivers/mfd/ac200.c
[ ... ]
> +static int ac200_probe(struct i2c_client *client)
> +{
> +	struct device *dev = &client->dev;
> +	struct ac200 *ac200;

[Severity: Low]
This isn't a bug, but should the private data structure instance be named
ddata instead of ac200? The MFD subsystem guidelines prefer the use of ddata
for variable instances to avoid hard-coding implementation details.

[ ... ]
> +static void ac200_shutdown(struct i2c_client *client)
> +{
> +	struct ac200 *ac200 = i2c_get_clientdata(client);

[Severity: Low]
This isn't a bug, but similar to ac200_probe(), should this use the ddata
naming convention for the variable instance?

[ ... ]
> +static const struct i2c_device_id ac200_i2c_ids[] = {
> +	{ "ac200" },
> +	{ }
> +};

[Severity: Low]
This isn't a bug, but should this array use named initializers to comply with
I2C subsystem initialization rules? For example, using { .name = "ac200" }.

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/[email protected]?part=2
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.