Re: [PATCH v3 0/7] mm/khugepaged: several cleanups
"Nico Pache (Red Hat)" <[email protected]>
| Newsgroups | org.kernel.vger.linux-doc,org.kernel.vger.linux-kernel,org.kvack.linux-mm |
|---|---|
| Message-ID | <[email protected]> |
On 8/4/26 5:12 PM, Andrew Morton wrote: > On Tue, 04 Aug 2026 13:24:58 -0600 "Nico Pache (Red Hat)" <[email protected]> wrote: > >> The following changes stem from a number of reviews during my khugepaged >> mTHP support series [1]. Some of these are minor code cleanups, issues or >> reviews that we decided to deferred to a followup series, or in the case >> of the more major patch of the series, changes [2] Lance Yang attempted >> while my series was in-flight and we decided to wait till later to try. >> >> The first 3 patches introduce helper functions to increase code reuse and >> readability. This includes a per-scan state clearing function, extracting >> the young page check into a helper, and a count_collapse_event() function >> to reduce a repetative pattern used across mTHP collapse. >> >> The 4th patch was the byproduct of me throwing Claude at all the >> comments in khugepaged verifying and looking for any outdated info. >> >> The 5th patch is based on Lance Yang's commit series [2] trying to extract >> the PTE state checking into a helper function. This required a bit of >> rewriting due to differences after mTHP collapse was introduced. I also >> took into account the changes requested during his patches review cycle. >> >> The remaining 2 patches were review points during my mTHP series that we >> agreed can be deferred to a later series. > > So "no functional change intended"? Correct, there should be no functional changes, other than the warn change. > > Sashiko had a little doc niggle: > https://sashiko.dev/#/patchset/[email protected] This doesnt seem to be relevant, although it may be good to move that note into its own block at some point. Cheers, -- Nico