Re: [PATCH 1/2] gpu: nova-core: gsp: retain the GSP-RM log buffers after unbind

John Hubbard <[email protected]>
Newsgroups org.kernel.vger.linux-doc,dev.linux.lists.nova-gpu,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On 8/13/26 9:29 AM, Timur Tabi wrote:
> On Wed, 2026-08-12 at 15:41 -0700, John Hubbard wrote:
>> And so should nova! (Except for the strangely worded "keep_gsp_logging"
>> param name.) See below.
> 
> The patch set that added that parameter to Nouveau was under review for months, and no one had
> any complaints about it until now.  Regardless of whether it's "strange", I think it's important

I'm not keeping a close eye on the nouveau list.

> that both Nouveau and Nova use the same parameter for the same functionality, so Nova should
> also call it "keep_gsp_logging".


Completely disagree. There is no need for these disparate drivers to share
a name, especially given that a better name is available. I'm quite
unhappy with your continuing efforts to add artificial constraints
along the lines of "nova must match nouveau", tbh.

Nothing is stopping nouveau from adopting nova's names, if that is
desirable from their end.


thanks,
-- 
John Hubbard
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.