Re: [PATCH 1/8] EDAC/{skx_common,i10nm,imh}: Move MC register access helpers to skx_common

Borislav Petkov <[email protected]>
Newsgroups org.kernel.vger.linux-edac,org.kernel.vger.linux-kernel
Message-ID <20260615022625.GAai9i0Zb3_9TVwIRf@fat_crate.local>
On Thu, May 21, 2026 at 03:31:05PM +0800, Qiuxu Zhuo wrote:
> Both i10nm_basic.c and imh_basic.c use identical helpers for accessing
> memory controller MMIO-based registers. Move these helpers to skx_common.c
> to eliminate code duplication. This change also prepares for an upcoming
> patch that will move RRL(retry_rd_err_log) code from i10nm_basic.c to

For the future:

Avoid having "This patch" or "This commit" in the commit message. It is
tautologically useless.

Also, do

$ git grep 'This patch' Documentation/process

for more details.

Also, there's no upcoming patch in git history either.

So please formulate your commit messages without referencing some patches
which no one would know about when reading this commit message in the future.

Also, in all your commit messages, do not explain what the code does - that's
visible from the diff itself. Rather explain why the patch exists.

Just several of things that I noticed while preparing the pull request.

We have a bunch of good suggestions here

https://docs.kernel.org/process/maintainer-tip.html

and in Documentation/process/submitting-patches.rst

Please read them and pay attention to that stuff in your future submissions.

Thx.

-- 
Regards/Gruss,
    Boris.

https://people.kernel.org/tglx/notes-about-netiquette
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.