Re: [PATCH 9/9] EDAC/versalnet: Use designated initializer for rpmsg_channel_info

"Pandey, Radhey Shyam" <[email protected]> Fri, 31 Jul 2026 19:56:10 +0530
Newsgroups org.kernel.vger.linux-edac,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On 7/24/2026 10:49 PM, Shubhrajyoti Datta wrote:
> Replace field-by-field assignment of struct rpmsg_channel_info with a
> designated initializer. This also fixes the incorrect use of strscpy
> with strlen which could lead to silent truncation of the channel name.
> 
> Fixes: d5fe2fec6c40 ("EDAC: Add a driver for the AMD Versal NET DDR controller")
> Signed-off-by: Shubhrajyoti Datta <[email protected]>
> ---
> 
>   drivers/edac/versalnet_edac.c | 10 +++++-----
>   1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/edac/versalnet_edac.c b/drivers/edac/versalnet_edac.c
> index ba295714d972..88b24eec4206 100644
> --- a/drivers/edac/versalnet_edac.c
> +++ b/drivers/edac/versalnet_edac.c
> @@ -720,14 +720,14 @@ MODULE_DEVICE_TABLE(rpmsg, amd_rpmsg_id_table);
>   
>   static int rpmsg_probe(struct rpmsg_device *rpdev)
>   {
> -	struct rpmsg_channel_info chinfo;
>   	struct mc_priv *pg;
> +	struct rpmsg_channel_info chinfo = {
> +		.src = RPMSG_ADDR_ANY,
> +		.dst = rpdev->dst,
> +		.name = "error_ipc",
> +	};

Nit - have a define for channel name and use it in both places.
Also swap above declaration order to align with reverse xmas style.

>   
>   	pg = (struct mc_priv *)amd_rpmsg_id_table[0].driver_data;
> -	chinfo.src = RPMSG_ADDR_ANY;
> -	chinfo.dst = rpdev->dst;
> -	strscpy(chinfo.name, amd_rpmsg_id_table[0].name,
> -		strlen(amd_rpmsg_id_table[0].name));
>   
>   	pg->ept = rpmsg_create_ept(rpdev, rpmsg_cb, NULL, chinfo);
>   	if (!pg->ept)