Re: [PATCH] arm64/mm: Rename ptdesc_t
Anshuman Khandual <[email protected]> Wed, 20 May 2026 11:08:02 +0530
| Newsgroups | org.kernel.vger.linux-efi,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On 20/05/26 10:56 AM, David Hildenbrand (Arm) wrote: > On 5/20/26 04:08, Anshuman Khandual wrote: >> >> >> On 19/05/26 4:32 PM, David Hildenbrand (Arm) wrote: >>> On 5/19/26 12:44, Will Deacon wrote: >>>> >>>> Yeah, the 'pxx' prefix really hurts my eyes. Please use something else! >>> >>> Fine with me as long as we don't call it something with "pte" in it. >>> >> >> Seems like there are two choices here >> >> (A) pxdval_t >> (B) ptval_t which Mike had suggested earlier >> >> Unless there is a preference will probably go with pxdval_t > > given it is ptdesc_t, ptval_t sounds better to me. > Sure - ptval_t it is.