Re: [PATCH 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
Lance Yang <[email protected]> Thu, 2 Jul 2026 20:25:15 +0800
| Newsgroups | org.kernel.vger.linux-fbdev,dev.linux.lists.virtualization,org.freedesktop.lists.dri-devel,org.freedesktop.lists.intel-gfx,org.freedesktop.lists.intel-xe,org.freedesktop.lists.nouveau,org.infradead.lists.linux-rockchip,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-mips,org.kernel.vger.linux-samsung-soc,org.kernel.vger.linux-sound,org.kernel.vger.linux-tegra,org.ozlabs.lists.linuxppc-dev,org.xenproject.lists.xen-devel |
|---|---|
| Message-ID | <[email protected]> |
On Mon, Jun 29, 2026 at 08:25:30PM +0100, Lorenzo Stoakes wrote: >Having vma_get_page_prot() refer to VMA flags and vma_set_page_prot() refer >to a VMA is confusing. > >Rename vma_get_page_prot() to vma_flags_to_page_prot() to resolve this >confusion. > >No functional change intended. > >Signed-off-by: Lorenzo Stoakes <[email protected]> >--- straight rename, no stale callers that I can spot ;) Feel free to add: Reviewed-by: Lance Yang <[email protected]>