Re: [PATCH v5 05/14] iio: light: lm3533-als: Remove redundant pdata helpers

Jonathan Cameron <[email protected]> Fri, 3 Jul 2026 01:57:35 +0100
Newsgroups org.kernel.vger.linux-fbdev,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-iio,org.kernel.vger.linux-kernel,org.kernel.vger.linux-leds
Message-ID <20260703015735.1403d1de@jic23-huawei>
On Wed, 17 Jun 2026 11:00:22 +0300
Svyatoslav Ryhel <[email protected]> wrote:

> The lm3533_als_set_input_mode() and lm3533_als_set_resistor() functions
> are used only in lm3533_als_setup(). Incorporate their code into
> lm3533_als_setup() directly to simplify driver readability.
> 
> Signed-off-by: Svyatoslav Ryhel <[email protected]>
LGTM
Reviewed-by: Jonathan Cameron <[email protected]>