[PATCH v4] staging: sm750fb: rename variables to comply with kernel style

AndrĂ© Moreira <[email protected]> Tue, 7 Jul 2026 10:15:28 -0300
Newsgroups org.kernel.vger.linux-fbdev,dev.linux.lists.linux-staging,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
Rename 'setAllEngOff' to 'set_all_eng_off' within the 'init_status'
struct to avoid CamelCase and comply with the Linux kernel coding style.

Signed-off-by: AndrĂ© Moreira <[email protected]>
---
v4:
  - Drop register renames 'pvReg' to 'regs' as they were merged via another upstream patch.
  - Keep only the 'init_status' CamelCase cleanup.

drivers/staging/sm750fb/sm750.h | 9 +++++++++
 1 file changed, 9 insertions(+)

diff --git a/drivers/staging/sm750fb/sm750.h b/drivers/staging/sm750fb/sm750.h
index 0324778768cbc..3a1bd38ab347a 100644
--- a/drivers/staging/sm750fb/sm750.h
+++ b/drivers/staging/sm750fb/sm750.h
@@ -39,6 +39,15 @@ enum sm750_path {
 	sm750_pnc = 3,	/* panel and crt */
 };
 
+struct init_status {
+	ushort power_mode;
+	/* below three clocks are in unit of MHZ*/
+	ushort chip_clk;
+	ushort mem_clk;
+	ushort master_clk;
+	ushort set_all_eng_off;
+	ushort reset_memory;
+};
 
 struct lynx_accel {
 	/* base virtual address of DPR registers */
-- 
2.43.0