Re: [PATCH v5 06/14] mfd: lm3533-core: Remove redundant pdata helpers
Svyatoslav Ryhel <[email protected]> Tue, 14 Jul 2026 16:32:40 +0300
| Newsgroups | org.kernel.vger.linux-fbdev,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-iio,org.kernel.vger.linux-kernel,org.kernel.vger.linux-leds |
|---|---|
| Message-ID | <CAPVz0n1groC-4MxU-sjyPEDHYWqAweyBmVNC+iX4mVa_D3SnDA@mail.gmail.com> |
пт, 3 лип. 2026 р. о 12:57 Johan Hovold <[email protected]> пише: > > On Wed, Jun 17, 2026 at 11:00:23AM +0300, Svyatoslav Ryhel wrote: > > The lm3533_set_boost_freq() and lm3533_set_boost_ovp() functions are used > > only in lm3533_device_setup(), which in turn is only called by > > lm3533_device_init(). Incorporate their code directly into > > lm3533_device_init() to simplify driver readability. > > Again, this isn't needed. Why are you removing abstraction that improve > readability? > Adding helpers to wrap custom regmap wrappers seems redundant. Regmap operations are pretty self explanatory without need in one-time-use helpers. > Johan