Re: [PATCH v2 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
"Vlastimil Babka (SUSE)" <[email protected]> Wed, 22 Jul 2026 16:36:00 +0200
| Newsgroups | org.kernel.vger.linux-fbdev,dev.linux.lists.virtualization,org.freedesktop.lists.dri-devel,org.freedesktop.lists.intel-gfx,org.freedesktop.lists.intel-xe,org.freedesktop.lists.nouveau,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-mips,org.kernel.vger.linux-samsung-soc,org.kernel.vger.linux-sound,org.kernel.vger.linux-tegra,org.kvack.linux-mm,org.ozlabs.lists.linuxppc-dev,org.xenproject.lists.xen-devel |
|---|---|
| Message-ID | <[email protected]> |
On 7/11/26 20:45, Lorenzo Stoakes wrote: > Having vma_get_page_prot() refer to VMA flags and vma_set_page_prot() refer > to a VMA is confusing. > > Rename vma_get_page_prot() to vma_flags_to_page_prot() to resolve this > confusion. > > No functional change intended. > > Reviewed-by: Lance Yang <[email protected]> > Reviewed-by: Zi Yan <[email protected]> > Signed-off-by: Lorenzo Stoakes <[email protected]> Reviewed-by: Vlastimil Babka (SUSE) <[email protected]>