Re: [PATCH v5 06/14] mfd: lm3533-core: Remove redundant pdata helpers
Johan Hovold <[email protected]> Fri, 31 Jul 2026 16:54:02 +0200
| Newsgroups | org.kernel.vger.linux-fbdev,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-iio,org.kernel.vger.linux-kernel,org.kernel.vger.linux-leds |
|---|---|
| Message-ID | <[email protected]> |
On Tue, Jul 14, 2026 at 04:32:40PM +0300, Svyatoslav Ryhel wrote: > пт, 3 лип. 2026 р. о 12:57 Johan Hovold <[email protected]> пише: > > > > On Wed, Jun 17, 2026 at 11:00:23AM +0300, Svyatoslav Ryhel wrote: > > > The lm3533_set_boost_freq() and lm3533_set_boost_ovp() functions are used > > > only in lm3533_device_setup(), which in turn is only called by > > > lm3533_device_init(). Incorporate their code directly into > > > lm3533_device_init() to simplify driver readability. > > > > Again, this isn't needed. Why are you removing abstraction that improve > > readability? > > > > Adding helpers to wrap custom regmap wrappers seems redundant. Regmap > operations are pretty self explanatory without need in one-time-use > helpers. They are clearly not as easy to read so this obscures what is being done and makes lm3533_device_init() harder to read. Johan