[GIT PULL] sysctl changes for v7.03-rc1
Joel Granados <[email protected]>
| Newsgroups | org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <zeiezeji5xxupnhdapw5pcsitpou7ysgzavigp3jnp5i2vhuik@zxklkd53i6gz> |
The following changes since commit 8cdeaa50eae8dad34885515f62559ee83e7e8dda:
Linux 7.2-rc2 (2026-07-05 14:44:06 -1000)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/sysctl/sysctl.git/ tags/sysctl-7.03-rc1
for you to fetch changes up to 8d75c338f0bcecaa6c9af67f86c176b67b6acf3e:
sysctl: remove CONFIG_PROC_SYSCTL, it just mirrors CONFIG_SYSCTL (2026-08-05 15:28:23 +0200)
----------------------------------------------------------------
Summary
* Documentation
Fix kernel-doc warnings by adjusting in file documentation.
* Consolidate do_proc_* function into do_proc_vec.
Consolidate three slightly different implementations of applying a converter
on all elements of a vector. Fixes to this function now propagate to the three
types.
* Miscellaneous
Replaced CONFIG_PROC_SYSCTL with CONFIG_SYSCTL (they were the same) and
restrict cad_pid modifications to global root (GLOBAL_ROOT_UID)
* Testing
This series was run through sysctl selftests/kunit test suite in x86_64. And
went into linux-next around rc2, giving it a bit more than a month of testing.
----------------------------------------------------------------
Joel Granados (6):
sysctl: Move default converter assignment out of do_proc_dointvec
sysctl: Add negp parameter to douintvec converter functions
sysctl: Replace do_proc_do{int,ulong,uint}vec with do_proc_vec
sysctl: Group proc_handler declarations and document
sysctl: Rename proc_doulongvec_minmax_conv to proc_doulongvec_conv
sysctl: Update API function documentation
Oleg Nesterov (2):
sysctl: move the "cad_pid" entry from pid_table[] to kern_reboot_table[]
sysctl: remove CONFIG_PROC_SYSCTL, it just mirrors CONFIG_SYSCTL
Randy Dunlap (2):
sysctl: add Returns: kernel-doc for all functions
sysctl: repair some kernel-doc comments
arch/m68k/configs/amcore_defconfig | 2 +-
arch/m68k/configs/stmark2_defconfig | 2 +-
arch/s390/Kconfig | 4 +-
arch/x86/kernel/cpu/bus_lock.c | 2 +-
fs/pipe.c | 2 +-
fs/proc/Kconfig | 3 +-
fs/proc/Makefile | 2 +-
fs/proc/internal.h | 2 +-
include/linux/sysctl.h | 131 +++--
include/linux/utsname.h | 2 +-
init/Kconfig | 3 -
kernel/delayacct.c | 2 +-
kernel/pid.c | 31 --
kernel/reboot.c | 29 ++
kernel/sched/core.c | 8 +-
kernel/sched/topology.c | 4 +-
kernel/sysctl.c | 528 +++++++++++----------
kernel/time/jiffies.c | 31 +-
kernel/utsname_sysctl.c | 4 +-
lib/Kconfig.debug | 2 +-
lib/test_sysctl.c | 2 +-
net/mpls/Kconfig | 2 +-
tools/testing/selftests/net/config | 2 +-
tools/testing/selftests/net/packetdrill/config | 2 +-
.../testing/selftests/wireguard/qemu/kernel.config | 2 +-
25 files changed, 451 insertions(+), 353 deletions(-)
signature.asc
(application/pgp-signature, 659 B)
-----BEGIN PGP SIGNATURE----- iQGzBAABCgAdFiEErkcJVyXmMSXOyyeQupfNUreWQU8FAmqC+6EACgkQupfNUreW QU8qDgv/VNzRaxbcsoQR/5OeSAT4yiv8tk6/0snXpcb/UcnlBUBBsjG1iCU4gHDc 8Qhsmq5E1K9U4hDJjkF9kOBpIlT6wl5NE3eIwK/LGwiovTMjZBAo5Jk+Hlon+ix9 TB4UofZTmgRoYsI95pf4Q7h3OcaSM2HkkJZ7QLpDZ5FS+i0rBxfs4Pni/b0P13U9 kZ+SooFMg46uc2Bl/J6OdIPoLn3o+rFR3Wn815iSPc2Jg/7MCl5DCxzXLPsCmG0P LeTXUUW+wBaxYSbpiRbGGg3phuoCjvbeOmZxheOr1gGvetx2BMyJ4rY7P6u3jjIT 4KbWhvFr187cQrcoLqcEmh2QcJFx9EgBKvZ6nPWIL9Tw73k2AnD8ZzJR4GSxo+KJ tnBSQqauxs9jyz3kkJzKS0jdYjq6MJl3ZmwIz4gzJmL8l2NRxLiUiANyVVYD+Ba+ mFblYjHMtyVMX5y+p3gbAHsBH/YsMffbDEW/RoE52BYwbepjaMmYHlogBS/LFY92 i0Q8Yv7e =mF+N -----END PGP SIGNATURE-----