Re: [PATCH 2/3] proc: query LSMs for introspective mem access (if PROC_MEM_FORCE_ALWAYS)
"Lorenzo Stoakes (ARM)" <[email protected]>
| Newsgroups | org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-security-module,org.kernel.vger.selinux,org.kvack.linux-mm |
|---|---|
| Message-ID | <aoibvf6CY99IXynk@gremlin> |
On Fri, Aug 21, 2026 at 04:48:32PM +0200, Jann Horn wrote: > On Fri, Aug 21, 2026 at 4:19 PM David Hildenbrand (Arm) > <[email protected]> wrote: > > On 8/20/26 20:44, Jann Horn wrote: > > > On Thu, Aug 20, 2026 at 7:22 PM David Hildenbrand (Arm) > > > <[email protected]> wrote: > > >> On 8/18/26 21:51, Jann Horn wrote: > > >>> If the system is running with PROC_MEM_FORCE_ALWAYS, LSMs currently have no > > >>> good opportunity to block a process from overwriting read-only code in its > > >>> own address space through FOLL_FORCE writes via /proc/self/mem. > > >>> The security_ptrace_access_check() LSM hook is bypassed when a process > > >>> opens /proc/self/mem because this is considered "introspection". > > >>> > > >>> This causes a hole in SELinux EXECMEM enforcement, which tries to ensure > > >>> that a process cannot create executable anonymous pages. > > >>> > > >>> PROC_MEM_FORCE_PTRACE prevents that and ensures that such FOLL_FORCE > > >>> accesses are only possible when the LSM allows ptrace() attachment; but it > > >>> is unclear how quickly PROC_MEM_FORCE_PTRACE can be deployed in > > >>> environments running lots of third-party code, such as Android. > > >>> > > >>> So, introduce a new LSM hook that can forbid FOLL_FORCE specifically for > > >>> such "introspective" accesses. > > >>> > > >>> Signed-off-by: Jann Horn <[email protected]> > > >>> --- > > >>> fs/proc/base.c | 6 ++++++ > > >>> include/linux/lsm_hook_defs.h | 1 + > > >>> include/linux/security.h | 6 ++++++ > > >>> security/security.c | 15 +++++++++++++++ > > >>> 4 files changed, 28 insertions(+) > > >>> > > >>> diff --git a/fs/proc/base.c b/fs/proc/base.c > > >>> index bec6197329dc..3dfaef49bb70 100644 > > >>> --- a/fs/proc/base.c > > >>> +++ b/fs/proc/base.c > > >>> @@ -851,6 +851,8 @@ static int __mem_open(struct inode *inode, struct file *file, unsigned int mode) > > >>> /* private_data for proc_mem_operations */ > > >>> struct mem_private { > > >>> struct mm_struct *mm; > > >>> + /* Was the ptrace access check bypassed due to introspection? */ > > >>> + bool introspection; > > >>> }; > > >>> > > >>> static int mem_open(struct inode *inode, struct file *file) > > >>> @@ -864,12 +866,14 @@ static int mem_open(struct inode *inode, struct file *file) > > >>> priv->mm = proc_mem_open(inode, PTRACE_MODE_ATTACH); > > >>> if (IS_ERR_OR_NULL(priv->mm)) > > >>> return priv->mm ? PTR_ERR(priv->mm) : -ESRCH; > > >>> + priv->introspection = priv->mm == current->mm; > > >> > > >> Is the feat that the fd could be passed to someone else that would then not be > > >> detected as introspection? > > > > > > Yes, exactly, that's the primary reason why I did it this way. > > > > Okay, would "opened_by_owner" or something like that be clearer? At least > > "introspection" is less intuitive for me. > > Ack, I'll rename it to something like that for the next version. I agree the naming is confusing. OK so the whole thing is: mem_open() -> __mem_open() -> proc_mem_open() -> mm_access() -> may_access_mm() And: static bool may_access_mm(struct mm_struct *mm, struct task_struct *task, unsigned int mode) { if (mm == current->mm) return true; ... } And what this flag is carrying is 'hey the reason we allowed the _open_ is because it's looking at its own address space'. I did wonder if what you're protecting against is even a process updating execmem _it_ owns, no fd shared anywhere, as something LSM might want to prevent even so? The sharing a /proc/mem fd seems like that's a pretty dumb thing to do in general :) but I guess you have to protect against that. But TL;DR I agree with David on the naming, opened_by_owner is probably the least-worst way of saying it very plainly and covers both cases. -- Cheers, Lorenzo