Re: [PATCH v4 1/2] ACPI: APD: Convert fixed clock rates to use HZ_PER_MHZ

Andy Shevchenko <[email protected]> Thu, 13 Aug 2026 10:35:41 +0300
Newsgroups org.kernel.vger.linux-i2c,org.kernel.vger.linux-acpi,org.kernel.vger.linux-kernel
Organization Intel Finland Oy - BIC 0357606-4 - c/o Alberga Business Park, 6 krs, Bertel Jungin Aukio 5, 02600 Espoo
Message-ID <[email protected]>
On Thu, Aug 13, 2026 at 02:30:04PM +0800, clarke.li wrote:

> Use HZ_PER_MHZ multiplier for fixed_clk_rate values to
> improve readability.

And actually increases robustness of the code as there is less chances
to miss a 0 or have an extra one.

Suggested-by: Andy Shevchenko <[email protected]>
Reviewed-by: Andy Shevchenko <[email protected]>

-- 
With Best Regards,
Andy Shevchenko