Re: [PATCH v2 2/5] ata: libata-scsi: refactor ata_scsi_report_supported_opcodes()
Damien Le Moal <[email protected]>
| Newsgroups | org.kernel.vger.linux-ide |
|---|---|
| Organization | Western Digital Research |
| Message-ID | <[email protected]> |
On 7/2/26 15:44, Hannes Reinecke wrote:
>> + { REPORT_LUNS, 12, false, 0 },
>> + { ATA_12, 12, false, 0 },
>> + { SECURITY_PROTOCOL_IN, 12, false, 0 },
>> + { MAINTENANCE_IN, 12, true, MI_REPORT_SUPPORTED_OPERATION_CODES },
>> + { SECURITY_PROTOCOL_OUT, 12, false, 0 },
>> +};
>
> This probably is a tough ask, but wouldn't it be better to
> move to named initializer?
> IE things like
>
> { .op = TEST_UNIT_READY, .cdb_len = 0, .sa_valid = false, .sa = 0 },
>
> that will not only make it easier to read, but will also be
> more user friendly if someone needs to expand the structure.
Arg. OK. Will do.
--
Damien Le Moal
Western Digital Research