Re: [PATCH v1 1/9] scsi: scsi_debug: move ASC and ASCQ definitions to scsi_proto.h

Damien Le Moal <[email protected]> Mon, 6 Jul 2026 17:55:22 +0900
Newsgroups org.kernel.vger.linux-ide,org.kernel.vger.linux-scsi
Organization Western Digital Research
Message-ID <[email protected]>
On 7/6/26 5:29 PM, Hannes Reinecke wrote:
> While at it, would you mind converting the raw asc/ascq numbers
> in drivers/scsi/scsi_lib.c to use these definitions?
> That will make the code in there _so much_ more readable ...

100% agree. And not just scsi_lib, but also sd.c, libata, etc. We have so many
places where ASC/ASCQ are hardcoded/hard to understand, that this will be a
great cleanup.

BUT, that's too much for this series. I was planning such cleanup as a follow-up.

-- 
Damien Le Moal
Western Digital Research