[PATCH] ata: libahci_platform: use of_platform_device_create() return value

Rosen Penev <[email protected]> Wed, 8 Jul 2026 18:42:30 -0700
Newsgroups org.kernel.vger.linux-ide,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
of_platform_device_create() already returns the struct platform_device
pointer, so there is no need for a separate of_find_device_by_node()
call. Use the return value directly.

Avoids having to free the reference from of_find_device_by_node().

Assisted-by: opencode:big-pickle
Signed-off-by: Rosen Penev <[email protected]>
---
 drivers/ata/libahci_platform.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/ata/libahci_platform.c b/drivers/ata/libahci_platform.c
index 6e072d681341..2aa3df58fc9a 100644
--- a/drivers/ata/libahci_platform.c
+++ b/drivers/ata/libahci_platform.c
@@ -617,10 +617,7 @@ struct ahci_host_priv *ahci_platform_get_resources(struct platform_device *pdev,
 			mask_port_map |= BIT(port);
 
 #ifdef CONFIG_OF_ADDRESS
-			of_platform_device_create(child, NULL, NULL);
-
-			port_dev = of_find_device_by_node(child);
-
+			port_dev = of_platform_device_create(child, NULL, NULL);
 			if (port_dev) {
 				rc = ahci_platform_get_regulator(hpriv, port,
 								&port_dev->dev);
-- 
2.55.0