Re: [PATCH v4 7/9] PCI: Make pci_match_one_device() match on ID instead of device
"Danilo Krummrich" <[email protected]> Sat, 25 Jul 2026 17:40:40 +0200
| Newsgroups | org.kernel.vger.linux-ide,dev.linux.lists.driver-core,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci,org.kernel.vger.linux-scsi,org.kernel.vger.netdev |
|---|---|
| Message-ID | <[email protected]> |
On Sat Jul 25, 2026 at 2:17 PM CEST, Gary Guo wrote: > On Fri Jul 24, 2026 at 11:29 PM BST, Bjorn Helgaas wrote: >> On Thu, Jul 23, 2026 at 11:00:46PM +0100, Gary Guo wrote: >>> PCI dynamic ID needs to match IDs against a new ID to see if it already >>> exists. Existing APIs can only match IDs against devices, causing the >>> dynamic ID insertion code to create a temporary device only for matchin= g >>> purpose. Rename pci_match_one_device() to pci_match_one_id() so it can = be >>> used for this purpose instead; add a pci_id_from_device() helper to mak= e it >>> easy to convert users. >> >> s/causing the ... code to create/so the ... code creates/ >> s/purpose/purposes/ >> >>> Similarly, convert pci_match_id() to do_pci_match_id(). But keep the >>> existing API because there are many users. >>>=20 >>> Reviewed-by: Danilo Krummrich <[email protected]> >>> Signed-off-by: Gary Guo <[email protected]> >> >> Reviewed-by: Bjorn Helgaas <[email protected]> >> Acked-by: Bjorn Helgaas <[email protected]> >> >> What's the merge strategy? If these all need to be merged together, >> feel free to include the PCI patches whereever you merge the series. > > I think the series should be merged together, as I consider the driver ch= anges > included in this series being "fixing the users". > > The series should probably be taken via the PCI tree. I suppose one can a= lso > argue that the lifetime issue with device IDs isn't unique to PCI bus so = this > can also be considered driver-core material, but given that Greg has alre= ady > taken the USB fixes via the USB tree the only unfixed bus left is PCI. > > So unless Danilo thinks otherwise I'd suggest the series be taken as a wh= ole via > PCI. I'm happy to take it through driver-core if it helps, but the PCI tree seem= s to be the natural fit. :)