Re: [PATCH 05/18] rust: kbuild: define `procmacro-extension` variable

Nicolas Schier <[email protected]>
Newsgroups org.kernel.vger.linux-kbuild,org.kernel.vger.rust-for-linux
Message-ID <[email protected]>
On Tue, Jun 02, 2026 at 07:29:06PM +0200, Miguel Ojeda wrote:
> Since we are adding one more proc macro crate (`zerocopy-derive`),
> we are refactoring their handling.
> 
> Thus, instead of using `libmacros_extension` as the common variable to
> hold the extension for all of them, use a dedicated variable with a more
> generic name (including for its implementation).
> 
> Signed-off-by: Miguel Ojeda <[email protected]>
> ---
>  rust/Makefile | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
> 
> diff --git a/rust/Makefile b/rust/Makefile
> index 8dfccf7399d9..df90fabefb70 100644
> --- a/rust/Makefile
> +++ b/rust/Makefile
> @@ -48,10 +48,9 @@ endif
>  ifdef CONFIG_RUST
>  
>  procmacro-name = $(shell MAKEFLAGS= $(RUSTC) --print file-names --crate-name $(1) --crate-type proc-macro - </dev/null)
> +procmacro-extension := $(patsubst libname.%,%,$(call procmacro-name,name))

Where does the 'libname.%' pattern come from?  Looking at the current
users of cmd_rustc_procmacro I'd expect a 'lib%' pattern instead.

-- 
Nicolas
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.