Re: [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id

Yushan Wang <[email protected]>
Newsgroups org.kernel.vger.linux-kernel
Message-ID <[email protected]>

On 8/4/2026 7:17 PM, Pawel Zalewski via B4 Relay wrote:
> From: "Pawel Zalewski (The Capable Hub)" <[email protected]>
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base.
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]>

Reviewed-by: Yushan Wang <[email protected]>

> ---
>  drivers/cache/hisi_soc_hha.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/cache/hisi_soc_hha.c b/drivers/cache/hisi_soc_hha.c
> index 756c43398515..f0f6c0354108 100644
> --- a/drivers/cache/hisi_soc_hha.c
> +++ b/drivers/cache/hisi_soc_hha.c
> @@ -170,7 +170,7 @@ static void hisi_soc_hha_remove(struct platform_device *pdev)
>  }
>  
>  static const struct acpi_device_id hisi_soc_hha_ids[] = {
> -	{ "HISI0511", },
> +	{ .id = "HISI0511" },
>  	{ }
>  };
>  MODULE_DEVICE_TABLE(acpi, hisi_soc_hha_ids);
>
> ---
> base-commit: 075b74841bd0065a3bda3440873c747938e69b68
> change-id: 20260803-cache-55f8e58f7d94
>
> Best regards,
> --  
> Pawel Zalewski (The Capable Hub) <[email protected]>
>
>
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.