Re: [PATCH v2 1/2] workqueue: Add missing EX PORT_SYMBOL_GPL for workqueue_set_min_active
Bradley Morgan <[email protected]>
| Newsgroups | org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On 10 August 2026 20:00:22 BST, Tejun Heo <[email protected]> wrote: >On Mon, Aug 10, 2026 at 06:34:30PM +0200, Håkon Bugge wrote: >> Adding a missing EXPORT_SYMBOL_GPL() in workqueue.c, as the >> workqueue_set_min_active() function is needed in the next commit. > >Can you just spell out who's gonna use it? I'm only cc'd on this one and >patch descs should be self-contained - it can reference future changes but >it should still be at least somewhat specific. > Mmm, shouldn't be complicated, perhaps Export workqueue_set_min_active() so that tests/loadable modules, e.g: test-ww_mutex can adjust workqueue concurrency levels to avoid deadlocks during cyclic test runs Again, feel free to bikeshed. >Thanks. > > Thanks!