[PATCH v3 0/2] mm/mm_init: simplify zone_spanned_pages_in_node()
Sang-Heon Jeon <[email protected]>
| Newsgroups | org.kernel.vger.linux-kernel,org.kvack.linux-mm |
|---|---|
| Message-ID | <[email protected]> |
Hello, This series simplifies zone_spanned_pages_in_node(), which adjusts *zone_start_pfn and *zone_end_pfn before and after calling adjust_zone_range_for_zone_movable(). The helper adjusts the same two values, which makes the code harder to follow. Patch 1 folds adjust_zone_range_for_zone_movable() into the caller, extracts zone_movable_pfn[nid] into a local variable, and reduces the indentation level. Patch 2 removes the clamping to node_end_pfn and moves the check and the clamping to node_start_pfn into the ZONE_MOVABLE branch, which is the only place they have an effect. It also merges the two branches that adjust for zone_movable_pfn[nid]. No functional change. --- Changes from v2 [2] - Squash patches 2 to 4 into one and fold patch 5 into patch 1, as Mike suggested Changes from v1 [1] - Change base to memblock/for-next - Add patch 4 to merge the two branches - Update comment [1] https://lore.kernel.org/all/[email protected]/ [2] https://lore.kernel.org/all/[email protected]/ --- Sang-Heon Jeon (2): mm/mm_init: fold adjust_zone_range_for_zone_movable() into its only caller mm/mm_init: simplify ZONE_MOVABLE branch in zone_spanned_pages_in_node() mm/mm_init.c | 79 ++++++++++++++++++++++++---------------------------- 1 file changed, 36 insertions(+), 43 deletions(-) -- 2.43.0