Re: [PATCH v2] sched/topology: Add a cpus_read_lock to rebuild_sched_domains()
Valentin Schneider <[email protected]>
| Newsgroups | org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On 13/08/26 09:38, Sebastian Andrzej Siewior wrote:
> Fixes: a7660ce1590fc ("sched/cache: Fix has_multi_llcs iff at least one partition has multiple LLCs")
> Signed-off-by: Sebastian Andrzej Siewior <[email protected]>
Reviewed-by: Valentin Schneider <[email protected]>
> @@ -273,6 +273,7 @@ static inline void dl_rebuild_rd_accounting(void)
>
> static inline void rebuild_sched_domains(void)
> {
> + guard(cpus_read_lock)();
Nit: When the indentation allows it I prefer scoped_guard()'s as I find
them more readable, but that's all personal preference so YMMV.
> partition_sched_domains(1, NULL, NULL);
> }
>
> --
> 2.55.0