Re: [PATCH v4 1/2] selftests/mm: rename local_config.h to local_config.h_gen
SJ Park <[email protected]> Mon, 3 Aug 2026 16:57:42 -0700
| Newsgroups | org.kernel.vger.linux-kselftest,org.kernel.vger.linux-kernel,org.kvack.linux-mm |
|---|---|
| Message-ID | <[email protected]> |
Hell Pratyush, My recipients checker found you are using the old email address of Liam, so added Liam's updated email to the recipients list. On Mon, 3 Aug 2026 22:17:31 +0000 [email protected] wrote: > From: Pratyush Mallick <[email protected]> > > Because local_config.h is a generated build artifact, un-ignoring all > .h files in .gitignore causes it to incorrectly show up as an untracked > file in git status. > > Rename it to local_config.h_gen so it no longer matches the !*.h > inclusion rule, preparing for a subsequent patch that switches > .gitignore to a pattern-matching approach. > > Update Makefile, check_config.sh, and affected test sources (cow.c, > gup_longterm.c) accordingly. Looks good to me. Thank you for accepting my humble suggestion or reordering. I found this patch cannot cleanly 'git am'-ed on mm-new, mm-unstable and even mm-stable. Maybe rebasing will be nice? > > Reviewed-by: Lorenzo Stoakes <[email protected]> > Acked-by: Mike Rapoport (Microsoft) <[email protected]> > Suggested-by: David Hildenbrand <[email protected]> > Signed-off-by: Pratyush Mallick <[email protected]> Reviewed-by: SJ Park <[email protected]> Thanks, SJ [...]