Re: [PATCH v2 03/11] m68k: mcf5441x: setup DAC clock name as per driver name
Greg Ungerer <[email protected]>
| Newsgroups | org.kernel.vger.linux-m68k,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-iio,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
Hi Angelo, On 14/5/26 17:05, Angelo Dureghello wrote: > Hi Greg, > > On 14.05.2026 11:27, Greg Ungerer wrote: >> Hi Angelo, >> >> On 13/5/26 19:14, Angelo Dureghello wrote: >>> From: Angelo Dureghello <[email protected]> >>> >>> Later in this patchset, the mcf54415 DAC driver is added. >>> Considering some other different ColdFire cpu DACs exists, the DAC driver >>> is named as "mcf54415_dac", related to the mcf5441x family SoCs with >>> DACs (mcf54415/6/7/8). >>> >>> So updating DAC clock names to bind with proper driver name. >> >> I am not sure I like naming the clocks here with a prefix for the >> specific SoC part number this is in. It might be unlikely now, but >> what if another ColdFire family SoC member uses this same hardware block? >> That is very common amongst other hardware blocks within the ColdFire >> family. Can we come up with a name more specific to just this type >> of DAC hardware block? >> > > from a brief study, this 12bit DAC, and DAC module in general, is only on > this mcf45441x family. There are some ColdFire with ADC only, as those > mcf5249/53/82. > The mcf51mm/ag/je are the opnly to have a 5bit dacs, but these are mcus. > So, if i don't miss any existing model, the name may be correct, > unless we want rename it to a more generic mcf_dac. Yes, I would suggest just leaving it as is, "mcfdac". That is not currently used by any other ColdFire variants supported by the kernel. Regards Greg >> Regards >> Greg >> >> > > Regards, > angelo >> >> >>> Signed-off-by: Angelo Dureghello <[email protected]> >>> --- >>> arch/m68k/coldfire/m5441x.c | 8 ++++---- >>> 1 file changed, 4 insertions(+), 4 deletions(-) >>> >>> diff --git a/arch/m68k/coldfire/m5441x.c b/arch/m68k/coldfire/m5441x.c >>> index 5b5e09ecf487..b724d7fc1a08 100644 >>> --- a/arch/m68k/coldfire/m5441x.c >>> +++ b/arch/m68k/coldfire/m5441x.c >>> @@ -43,8 +43,8 @@ DEFINE_CLK(0, "mcfpit.2", 34, MCF_BUSCLK); >>> DEFINE_CLK(0, "mcfpit.3", 35, MCF_BUSCLK); >>> DEFINE_CLK(0, "mcfeport.0", 36, MCF_CLK); >>> DEFINE_CLK(0, "mcfadc.0", 37, MCF_CLK); >>> -DEFINE_CLK(0, "mcfdac.0", 38, MCF_CLK); >>> -DEFINE_CLK(0, "mcfdac.1", 39, MCF_CLK); >>> +DEFINE_CLK(0, "mcf54415_dac.0", 38, MCF_CLK); >>> +DEFINE_CLK(0, "mcf54415_dac.1", 39, MCF_CLK); >>> DEFINE_CLK(0, "mcfrtc.0", 42, MCF_CLK); >>> DEFINE_CLK(0, "mcfsim.0", 43, MCF_CLK); >>> DEFINE_CLK(0, "mcfusb-otg.0", 44, MCF_CLK); >>> @@ -106,8 +106,8 @@ static struct clk_lookup m5411x_clk_lookup[] = { >>> CLKDEV_INIT("mcfpit.3", NULL, &__clk_0_35), >>> CLKDEV_INIT("mcfeport.0", NULL, &__clk_0_36), >>> CLKDEV_INIT("mcfadc.0", NULL, &__clk_0_37), >>> - CLKDEV_INIT("mcfdac.0", NULL, &__clk_0_38), >>> - CLKDEV_INIT("mcfdac.1", NULL, &__clk_0_39), >>> + CLKDEV_INIT("mcf54415_dac.0", NULL, &__clk_0_38), >>> + CLKDEV_INIT("mcf54415_dac.1", NULL, &__clk_0_39), >>> CLKDEV_INIT("mcfrtc.0", NULL, &__clk_0_42), >>> CLKDEV_INIT("mcfsim.0", NULL, &__clk_0_43), >>> CLKDEV_INIT("mcfusb-otg.0", NULL, &__clk_0_44), >>> >>