Re: [PATCH v1 0/8] zorro: Improve handling of pointers in zorro_device_id::driver_data
Geert Uytterhoeven <[email protected]>
| Newsgroups | org.kernel.vger.linux-m68k,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-fbdev,org.kernel.vger.linux-i2c,org.kernel.vger.linux-ide,org.kernel.vger.linux-kernel,org.kernel.vger.linux-scsi,org.kernel.vger.netdev |
|---|---|
| Message-ID | <CAMuHMdUVoNg-rSV_hDcvi6KCosmE=SMcxUj2Y8fkoJ=33zMSXw@mail.gmail.com> |
Hi Uwe, On Tue, 26 May 2026 at 16:17, Uwe Kleine-König (The Capable Hub) <[email protected]> wrote: > this series is about improving the handling of pointers in struct > zorro_device_id's driver_data. > > While it's ok on all current Linux platforms to store a pointer in an > unsigned long variable, it involves casting that loses type information. > This can be nicely seen in patch #7 where after profiting from patch #6 > the compiler notices a missing const. > > Preparing for that change, all zorro_device_ids are converted to use > named initializers, which is also a nice cleanup that could stand for > itself, as it improves readability for humans. (That is necessary > because an anonymous union can be initialized by name, but not using a > list initializer.) > > My motivation for this series is the CHERI hardware extension. With that > pointers are bigger than longs and thus you cannot store pointers in > zorro_device_id::driver_data. So this series is also about getting > support for CHERI into the mainline, but I hope the clean up effects > mentioned above are justification enough to accept this series. Thanks for your series! > The dependencies in this series are as follows: > > - Patch #5 depends on #1, #2 s/5/6/? > - Patches #7 and #8 depend on patch #6. > > So if the ata maintainers agreed to merge their patch #1 via scsi, and > Geert agrees to patch #5 and that it's also merged via scsi, patches #1, s/5/6/? > #2, #6 and #7 can go in without further coordination. > > Patches #3, #4 and #5 are only about using the same initialization style > for all zorro_device_id and can go in without coordination. > > Best regards > Uwe > > Uwe Kleine-König (The Capable Hub) (8): > ata: pata_budda: Use named initializer for zorro_device_id > scsi: Use named initializer for zorro_device_id > net: Use named initializer for zorro_device_id arrays > i2c: icy: Use named initializer for zorro_device_id arrays > video: fm2fb: Use named initializer for zorro_device_id array > zorro: Simplify storing pointers in device id struct > scsi: zorro7xx: Make use of struct zorro_device_id::driver_data_ptr > video: cirrusfb: Make use of struct zorro_device_id::driver_data_ptr Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected] In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds