Re: [PATCH 01/31] swim: Assert strobe with stable outputs
Finn Thain <[email protected]> Tue, 21 Jul 2026 17:37:04 +1000 (AEST)
| Newsgroups | org.kernel.vger.linux-m68k,org.kernel.vger.linux-block,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
This message is in MIME format. The first part should be readable text, while the remaining parts are likely unreadable without MIME-aware tools. --83233281352656579178461942438 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: QUOTED-PRINTABLE On Tue, 21 Jul 2026, Laurent Vivier wrote: > Le 21/07/2026 =C3=A0 07:41, Finn Thain a =C3=A9crit=C2=A0: > >=20 > > On Mon, 20 Jul 2026, Laurent Vivier wrote: > >=20 > >> Le 16/07/2026 =C3=A0 12:02, Finn Thain a =C3=A9crit=C2=A0: > >> > >>> Keep the four phase pin directions set to output and hold their level= s > >>> constant during LSTRB signalling. > >> > >> Perhaps you can also add a short comment to describe the changes you > >> made to the defines. > >> > >=20 > > Can you clarify please? I think what you're asking is, shouldn't the PH= 3 > > pin be an input when it's not being used for LSTRB signalling? >=20 > My question is simpler: > You added the directions bits in the defines and it's not clear in the co= mmit > message. > For instance, I can see you update all the defines, but at first glance I > didn't understand why. >=20 OK -- I see what you mean. It might be more idiomatic and more readable if= =20 the the pin direction nybble were defined in a separate macro rather than= =20 baked into every macro definition. E.g. #define PHASE_PIN_DIRECTION 0xF0 The writes to the phase register would then get a bitwise OR with this new= =20 macro. Would that work for you? --83233281352656579178461942438--